Elite Group - Outage
Incident Report for Big Blue Rocket
Resolved
This incident has been resolved.
Posted 3 months ago. Jan 28, 2019 - 11:10 GMT
Identified
We are aware of a major issue one of our voice communications is experiencing.

There is current no resolution time avaliable.
Posted 3 months ago. Jan 28, 2019 - 03:30 GMT
This incident affected: Voice Communications.